
Conversione di un file TS in DivX by VincentVega (v.1.0)
________________________________________________________

_______________________________________________________________________
PREMESSA:
   In questo piccolo documento troverete la procedura, che in base alle 
   prove che ho effettuato mi e' risultata piu' semplice, veloce e con 
   il miglior rapporto qualita'/dimensione del file.
   Non esiste una procedura unica perche' ognuno ha una sua idea di 
   "qualità" e ognuno preferisce usare i programmi con i quali si trova 
   piu' a suo agio.
   Potete pubblicare e scambiare liberamente questo file ricordandovi
   pero' di citare l'autore.
_______________________________________________________________________

Il nostro Dreambox registra il flusso audio/video nel formato TS 
(transport stream).
Un file TS e' un file mpeg2 con delle informazioni addizionali,
riguardanti la trasmissione, che non ci interessano.

Scaricate questi programmi:

− PVA Strumento (www.offeryn.com)
− Mpeg Mediator (www.mpeg−mediator.com)
− VirtualDub (virtualdub.sourceforge.net)
− NanDub
− TMPGenc (www.tmpgenc.net)
− CoolEdit 2000 (www.syntrillium.com)
− GSpot (www.headbands.com/gspot)
− Codec e player DivX (www.divx.com)
− Codec Fhg Fraunhofer−Radium MP3

Per semplificare la comprensione dei vari passaggi possiamo riassumere
le operazioni da effettuare:

Video
− Da Ts ad Mpeg2 con PVA Strumento
− Da Mpeg2 a Divx con MpegMediator 
− Editing dei files DivX con VirtualDub (pubblicita' ecc)
− Unione dei vari files DivX con VirtualDub

Audio
− Da Ts a Mpa con PVA Strumento
− Da Mpa a Wav con TMPgenc
− Da Wav a Mp3 con CoolEdit 2000

Uno dei problemi che ho incontrato le prime volte che ho creato
dei file DivX e' la mancanza di sincronismo tra audio e video
ed e' veramente frustrante aver aspettato la fine della conversione
di un file e poi accorgersi che qualcosa e' andato storto.

Da quanto ho capito sembra che il problema del sincronismo 
sia generato dall'audio compresso in mp3. Sembra che 
i files mp3 essendo dei files compressi non si miscelino
correttamente con i pacchetti dei dati video, si creano
quindi delle differenze di lunghezza tra un pacchetto audio
e uno video >> vengono uniti lo stesso >> si genera la perdita
di sincronismo.

Per ovviare preferisco trasformare il flusso audio in mp3 solo
alla fine di tutta la procedura.
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Altra considerazione: ho notato che fare una miscelazione di
audio e video partendo da due files separati e' piu' veloce
rispetto all'elaborazione di un unico file. 
Quindi anche se dividere il filmato in "file video + file audio", 
vi puo' sembrare all'inizio una scelta sbagliata, proprio per 
evitare di dover rifare tutta la procedura da capo piu' e piu' 
volte (e perdere tempo), vi consiglio di dividerli, elaborarli 
e alla fine miscelarli.

Iniziamo.

_______________________________________________________________________
PVA Strumento  (da Ts a Mpeg)

Input Stream > carico il file TS (vedi la parte "nomi dei files Ts" )
Make PS >   Mpeg  > scelgo dove salvare il file ed il suo nome
            Video > deseleziono tutto
            Expert > deselezionare le due voci DROP

                   NB. ho notato che questo programma non fa' miracoli, 
                       se ci sono dei Frames mancanti non ve li recupera
                       e le opzioni non ci aiutano..
                       Le opzioni Drop tagliano completamente la scena
                       dove c'e' anche un solo frame mancante, e il taglio
                       a me risulta particolarmente fastidioso.

Start > abbiamo ottenuto un file Mpeg

Il programma inizia la conversione del file TS, vi mostra 
gli eventuali errori incontrati e vi genera un file txt di log.
Il problema dei frames mancanti puo' dipendere da diversi fattori:
− firmware del DreamBox
− hard disk troppo lento/alimentato male/surriscaldato (es.dopo 10 ore di rec)
− caratteristiche particolari della trasmissione del provider
− termine scrittura di un file TS e inizio di un nuovo file

Quando ci sono dei frames video o audio mancanti quasi sicuramente
incontrerete dei problemi di sincronismo, quindi preparatevi 
psicologicamente...
Un file TS ha come dimensione massima 1 gb, ho notato che 
al momento del raggiungimento di questa dimensione, quando
cioe' il DreamBox deve chiudere il file in corso e crearne uno
nuovo perde alcuni frames.
Se cio' che state registrando e' una trasmissione tv con la
pubblicita' vi consiglio di stoppare la registrazione e di
riavviarla quando sta' per ricominciare (Mediaset in genere
usa come ultimo spot la presentazione di un programma).

_______________________________________________________________________
PVA Strumento (da Ts a Mpa)

Input Stream > carico il file TS
Demux >      General > deselezionare Video
                       selezionare Audio > scelgo dove salvare il file 
                                           ed il suo nome 
                       deselezionare le due opzioni (Fix e Sync.)
             Audio > lasciare l'opzione Split
             Expert > deselezionare le due voci DROP
Start > abbiamo ottenuto un file Mpa (audio)

_______________________________________________________________________

TMPgenc (da Mpa a Wav)
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Chiudere la schermata iniziale sui profili.

Audio source     > Browse > caricare il file mpa da convertire
Stream type      > ES (audio only)
Output file name > Scegliere dove salvare il file wav ed il suo nome
Settings         > Stream type > Linear PCM
                   Sampling freq > 48.000
                   Channel mode > Stereo
                   OK

Start > Abbiamo convertito il file Mpa in Wav.

_______________________________________________________________________
Mpeg Mediator (da Mpeg a DivX)

File > Open > Add > Scegliere il file Mpeg da convertire > Apri > Ok

Output > Selezionare OpenDML AVI Output
         Selezionare Export frames in YV12
         Set Output file > Scegliere dove salvare il file DivX ed il suo nome
         Configure Plugin > (vedi in basso)

Audio Tracks > No Audio
Filters > Lasciare le impostazioni presenti su : Aspect Ratio, Resizing e Cropping
          Deinterlacing > Off
Start > Convert n frames > inserire 2.000 e OK per convertire una piccola 
                           parte del filmato, se la qualita' ci 
                           soddisfa > Convert All Frames 

       Convert All Frames > inizia la conversione di tutto il file
                            View > NO Frames/All frames mostra il filmato mentre 
                                   e' in corso la conversione, chiaramente rallenta
                                   l'operazione di conversione
Barra di scorrimento in basso > Si puo' iniziare la conversione scegliendo
                                con la barra un punto di inizio del filmato.
                                Non fatelo altrimenti dovrete trovare il punto 
                                d'inizio anche nel file audio e farlo combaciare
                                poi con il video (e vi assicuro che non e' semplice...)

Configure PlugIN 
________________
Questa opzione e' la piu' importante ai fini del risultato finale.
Scegliamo una bassa qualita' ed un file piccolo oppure alta qualita'
e un file enorme da dividere in piu' cd?
Personalmente preferisco la qualita' e risoluzione massima (704 x 528 − 25fps) 
usando due cd.
A voi la scelta.

Video Codec > scegliere DivX Pro 5.05 Codec e cliccare su Configure
Quick Config CLI > copiare la stringa tra parentesi esattamente com'e', 
                   potete anche copiare una particolare configurazione 
                   e quando vi serve basta incollarla in questo punto
(−bv1 1500 −psy 0 −key 10000 −b −sc 0 −pq 5 −vbv 8000000,6291456,4718592 −profile 4 )  

Variable Bitrate mode > 1−pass
Bitrate Control > Encoding Bitrate > 1500  (1 ora circa 700 mb)
General Parameters > Tutto deselezionato
                     Max Keyframe > 10000 
                     Scene change threshold > 0 %
                     Performance/quality > Slowest
                     Source Interlace > Encode as progressive

               NB Il Keyframe e' un'immagine chiave che contiene tutti i dati
                  di quel fotogramma, essendo la piu' ricca e' anche la piu'
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                  grande come dimensione. Inserendo troppi keyframe avremo un
                  file finale gigantesco quindi dobbiamo inserire i KF solo
                  quando sono necessari. Quando lo sono? Quando cambiano totalmente
                  le scene. Se inseriamo un solo ed unico KF per tutto il filmato
                  oltre ai problemi di editing avremo una qualita' sempre piu'
                  scadente man mano che il filmato avanza. E' per questo che 
                  uso la Soglia di Sensibilita' per il cambio scena a 0%, perche'
                  in questo modo verra' inserito un KF quando e' necessario.

Profiles > Use Bidirectional Encoding
Cliccare su OK
Cliccare su OK

Una volta cliccato su Start Convert possiamo farci un giretto.
Al termine avremo ottenuto un file DivX video.
Se stiamo trasformando piu' parti di uno stesso filmato ricordatevi
che le impostazioni devono essere le stesse per tutti i pezzi, 
altrimenti non riuscirete ad unirle.
Ripetete la procedura per ogni file Mpeg da convertire.

____________________________________________________________________________________
VirtualDub (file video DivX + file audio Wav)
Open Video File > apre il file video AVi che abbiamo creato con Mpeg Mediator
Video > Direct Stream Copy
Audio > Wav Audio > selezionare il corrispondente file Wav creato con TmpGenc
        Direct Stream Copy
File > Save As Avi > Scegliere dove salvare ed il nome del file
______________________________________________________________________________
DivX Player
Aprire il file DivX appena creato e verificare il sincronismo tra audio e video.
Se e' tutto OK ripetiamo la procedura VirtualDub per un altro file

_____________________________________________________________________________
CoolEdit 2000  (risolvere il problema di sincronismo)
Se si e' verificato un problema di sincronismo dobbiamo capire se:
− l'audio e' in anticipo rispetto al video > prima parla e poi muove la bocca 
  (audio frame missing)
− l'audio e' in ritardo  rispetto al video > prima muove la bocca e poi parla 
  (video frame missing)

Chiamero' punto X il momento in cui si verifica la perdita di sincronismo.

− Nel primo caso (audio in anticipo) dobbiamo semplicemente individuare il 
  punto X (con il player), memorizzarlo ed inserire un po' di silenzio nel 
  punto piu' idoneo e piu' vicino possibile al punto X.

Per aiutarci ad individuare il punto X controlliamo anche i files di log 
creati da PVA Strumento, lì c'e' scritto in che punto si e' verificato una 
perdita di frames>perdita di sincronismo.

Apriamo CoolEdit2000
File > Open > Apriamo il file Wav 

In basso c'e' l'indicatore temporale, clicchiamo in prossimita' del punto X
Apparira' una barra verticale che indichera' il punto preciso in cui ci troviamo.
Con la rotella del mouse possiamo fare uno Zoom In/Out.

La barra di scorrimento in alto ci permettera' di spostarci a destra o a sinistra.
Tenendo premuto il pulsante sinistro del mouse possiamo selezionare una porzione
del file ed ascoltarlo, cosi' come potremo fare copia, taglia incolla 
(ctrl+c,ctrl+x,ctrl+v).

Trovato il punto X dobbiamo individuare dove poter inserire un po' di silenzio
 − possiamo copiare una parte dove e' gia' presente il silenzio
 − posizionarci in un punto dove c'e' lo spot pubblicitario e trasformare
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   una porzione di audio in silenzio.

Individuato il punto d'inserimento del silenzio posizioniamo la barra in quel 
punto preciso.
Facciamo Copia e Incolla della porzione di silenzio che abbiamo creato.
Save e Exit.

In genere ho notato che 450/500 ms di silenzio vanno quasi sempre bene.
Per ottenere la perfezione bisogna fare piu' prove aggiungendo di volta 
in volta 50 ms in piu' fino a riottenere il sincronismo audio/video.

Per trasformare una parte in silenzio:
− selezionare una porzione di file
− Transform > Silence

Per fare una selezione precisa:
premere la freccia sinistra   per selezionare all'indietro rispetto alla barra
premere Shift+freccia destra  per selezionare in avanti rispetto alla barra

La durata della selezione la potete controllare nel riquadro in basso 
a destra (lenght).

− Nel secondo caso (audio in ritardo) dobbiamo compensare la mancanza di 
  qualche frame video mancante togliendo un po' di audio.

Non possiamo tagliare l'audio mentre e' in corso una conversazione, 
quindi con CoolEdit dobbiamo individuare il punto piu' idoneo e piu' 
vicino possibile al punto X dove nessuno parla o dove c'e' silenzio 
e tagliare una porzione di audio.

Come prima io in genere inizio con 450 ms, salvo il file wav 
(con altro nome), apro VirtualDub, unisco il file video con il 
file wav e con il player verifico il sincronismo.

Se non c'e' un unico frammento di 450 ms da poter tagliare possiamo 
sommare due frammenti fino ad ottenere i 450ms da tagliare 
(es. 200ms + parlato + 250ms).

Ottenuto il file audio corretto rifacciamo la parte "VirtualDub 
(file video DivX + file audio Wav)".

Ricordatevi che correggere il sincronismo in una porzione di file 
e' importantissimo, se non lo fate al momento dell'assemblaggio 
delle varie parti si tramandano gli errori 
sul resto del filmato.

_________________________________________________________________________
VirtualDub (selezione scene, eliminazione pubblicita')

Se siamo stati fortunati i vari frammenti del filmato avevano un perfetto 
sincronismo audio/video. Procediamo ora ad editarli togliendo la pubblicita'.

Open Video File > apriamo il primo file Avi
Spingendo Shift + freccia (dx o sx) ci spostiamo al successivo/precedente KeyFrame
In questa fase ci accorgeremo quanto e' utile "Scene Change Threshold" a 0%.
Individuata la scena iniziale clicchiamo sul pulsante di inizio selezione (  )

Video > Direct Stream Copy
Audio > Source Audio
        Direct Stream Copy
File  > Save as Avi > salviamo il file e diamogli un nome

Controlliamo il file ottenuto con DivX player.

Se purtroppo il KeyFrame non ricade esattamente nel punto in cui ci interessa
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tagliare il filmato rimarra' qualche frame di pubblicita'.
In questo caso, per eliminarla del tutto, possiamo operare in diversi modi:

− Scegliere su Video "Full Processing Mode" che pero', se la porzione e' 
  molto lunga, richiede tempo. Ricordiamoci di controllare le opzioni 
  "Compression" su Video.

− Perdere un pezzo di filmato fino a raggiungere il KeyFrame 
  (solo se il pezzo che tagliamo non e' interessante pero'!!!)

− spezzare il file in 3 parti, e fare il "Full Processing Mode" 
  solo nella parte centrale (2), la parte 1 e 3 verranno messe da parte 
  e i 3 pezzi verranno poi riassemblati una volta ottenuta la parte 2 
  rielaborata.

Abbiamo ottenuto la versione definitiva del frammento video.

______________________________________________________________________________
VirtualDub (unione dei frammenti)

Ora dobbiamo unire i vari frammenti fino ad ottenere un unico file Avi,
la cui parte video e' quella definitiva.

File > Open Video File    > Apriamo il file_parte1
File > Append Avi Segment > Apriamo il file_parte2
File > Append Avi Segment > Apriamo il file_parte3   
                            e cosi' via fino ad unire tutti i pezzi.

Video > Direct Stream Copy
Audio > Source Audio
        Direct Stream Copy
File  > Save as Avi > salviamo il file e diamogli un nome

Abbiamo ottenuto il file definitivo, l'audio pero' non e' compresso (e' ancora Wav).
Verifichiamo con DivX player che nella parte centrale e finale non ci siano perdite
di sincronismo. Se alla fine del filmato c'e' sincronia vuol dire che il filmato
va' bene.

File > Close Video File
File > Open Video File    > Apriamo il file_finale
File > Save Wav > Diamo un nome al file Wav e salviamolo
______________________________________________________________________________
CoolEdit 2000 (da Wav a Mp3)

E' ora di comprimere il file Wav in Mp3.
File > Open > Apro il file Wav_finale
File > Save As > Converto il file Wav in Mp3
                 Salva Come: MPEG 3 (FhG)(*.mp3)
                 Options > CBR (constant Bitrate) 128 Kbps, 48000 Hz, Stereo > Ok
                 Scelgo un nome > Salva

_____________________________________________________________________________
NanDub (file DivX + audio Mp3)

VirtualDub non riesce a miscelare un file Avi/DivX con un file audio Mp3,
per farlo devo usare una versione modificata chiamata NanDub.

File > Open Video File    > Apriamo il file_finale.avi
Audio > (VBR) Mp3 file    > Apro il file mp3 appena creato
                            Direct Stream Copy
Video > Direct Stream Copy
File > Save As Avi > Scelgo un nome e salvo

Finito.

6



Ho ottenuto il file DivX con audio Mp3 finale.
Possiamo controllare con G−Spot le caratteristiche del file
che abbiamo creato e verificare la compressione (divX e Mp3).

________________________________________________________________________
Nomi dei Files Ts
Il DreamBox crea durante la registrazione dei files con estensione *.ts
(dimensione massima 1 Gb) dandogli un nome sequenziale:

NomeCanale − NomeProgramma.ts        (registrazione continua)
NomeCanale − NomeProgramma.ts.001
NomeCanale − NomeProgramma.ts.002
NomeCanale − NomeProgramma.ts.003

Nel caso in cui la registrazione sia interrotta e ripresa successivamente
(es dopo la pubblicita') la numerazione e' sempre sequenziale ma differente:

NomeCanale − NomeProgramma.ts       (registrazione stoppata e ripresa)
NomeCanale − NomeProgramma[2].ts
NomeCanale − NomeProgramma[3].ts

Questi due modi possono anche mischiarsi quando uno dei file supera il gb:

NomeCanale − NomeProgramma.ts
NomeCanale − NomeProgramma.ts.001
NomeCanale − NomeProgramma[2].ts
NomeCanale − NomeProgramma[2].ts.001
NomeCanale − NomeProgramma[2].ts.002
NomeCanale − NomeProgramma[3].ts
NomeCanale − NomeProgramma[3].ts.001

Nella directory /hdd/movie troverete il file recordings.epl nel quale sono 
elencati i files creati dal dreambox durante le registrazioni.

#NAME recorded movies
#SERVICE: 1:0:1:1:1770:110:820000:0:0:0:/hdd/movie/NomeCanale − NomeProgramma.ts
#DESCRIPTION: no description available
#TYPE 16385
/hdd/movie/NomeCanale − NomeProgramma.ts
#SERVICE: 1:0:1:1:1770:110:820000:0:0:0:/hdd/movie/NomeCanale − NomeProgramma[2].ts
#DESCRIPTION: no description available
#TYPE 16385
/hdd/movie/NomeCanale − NomeProgramma[2].ts

Se volete riordinare o rinominare i files ts presenti nell'hard disk
dovete anche editare il file recordings.epl cambiando solo l'ultima parte
delle stringhe #SERVICE e /hdd/movie/ (dopo #TYPE) mettendo il nuovo nome 
del file ts.

_______________________________________________________________________________
Come diminuire la dimensione del file?

− si puo' abbassare il bitrate portandolo ad un valore piu' basso di 1500

− si puo' scegliere di processare il file in due mandate con l'opzione
  (del codec DivX) Multiprocessing Mode che pero' richiedera' molto piu' tempo

− scegliere al posto di una risoluzione 704x528/704x576 una risoluzione piu' 
  bassa (es 352x264/352x288)

− diminuire il valore fps (frames per second) che in genere e' 25, questo pero'
  genera una perdita di qualita' e degli "scatti" nelle scene di azione.

− se stiamo elaborando un file di un film con poche scene di azione possiamo
  alzare la "Scene Change Threshold" al 50% o sup. anche se questo ci creera' 
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  dei problemi nell'editing (impiegheremo piu' tempo per il Full Proc.Mode)

− alzare il valore "Max Keyframe", la qualita' pero' diminuira' progressivamente

− diminuire la qualita' audio scegliendo dei valori piu' bassi 
  (es. 112Kbs, 80Kbs,64Kbs)
________________________________________________________________________________________

by VincentVega
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